Berichten over ‘ubuntu’

KMess: klikbare links met het juiste programma openen

Friday, 16 January 2009

Het líjkt vanzelfsprekend. Je klikt op een link in een chatvenster en  hopla! de link opent in je browser en brengt je zo, zonder extra muisklikken, naar de juiste website, afbeelding of wat dan ook….

Totdat…. je chatprogramma alles doet behálve het juiste programma gebruiken… en een link naar youtube achtereenvolgens opent in zowat alle programma’s die op je pc te vinden zijn, maar net dat ene programma (een browser, firefox bv) niet. Frustrerend!

Blijkt dat KMess voor kde geschreven is… wat die k eigenlijk al deed vermoeden. En de browser in kde is nu niet dezelfde als die in gnome (waar ubuntu mee werkt).
Probleem dus. Of toch niet?
Er is een faq op de website van KMess.. en jawel hoor… mét een antwoord.

Ga naar ~/.kde/share/config/kdeglobals en voeg daaraan het volgende toe:

[General]
BrowserApplication=firefox

Als de [General] sectie nog niet bestaat, zul je het zelf moeten toevoegen.

Zo zie je maar, hoe simpele dingetjes soms voor enorme frustraties kunnen zorgen…. 😉


Ook dit is Linux

Tuesday, 31 March 2009

Een tijdje geleden had ik een blog-post geschreven over Linux . Er werkte al veel, maar nog niet alles.
Er is de laatste tijd veel veranderd en het is de moeite waard om dat met de wereld te delen.
Eerst en vooral heb ik een theme gevonden waarvan ik dacht: eindelijk!
De standaard layout van Ubuntu vind ik persoonlijk spuuglelijk en ik was dan ook blij verrast toen er een mooie grafische schil beschikbaar was.

Bureaublad

Verder is ook de Avant Window Navigator (Awn) volwassen geworden en beschikt nu over een aantal ongelooflijk handige applets zoals een kalender, mail-alert en een mini-weerbericht.

Avant Window Navigator (awn)

Mits het installeren van een paar Addons (Last track Resume, MMKeys, Song notifier, The Exorcist, FocusTrack) is Songbird een prima muziekspeler in Ubuntu en een waardig alternatief voor iTunes (vind ik).
Je kan Songbird zelfs met je iPod/iPhone besturen!

En last but not least: eindelijk word m’n webcam ondersteund! (Trust 15007)
Dankzij http://groups.google.com/group/microdia/web/testing-microdia-driver-draft

Webcam en Songbird werken probleemloos

Zodoende: Linux als primair os gebruiken: poging 2.


Een partitie permanent mounten in Ubuntu

Sunday, 12 April 2009

Ik heb op m’n laptop verschillende partities… één daarvan dient om afbeeldingen in op te slaan.
Alleen… als ubuntu opstart moet ik die handmatig mounten. (via Locaties > <Naam van de partitie> )

Niet echt lastig als je naar die map wilt gaan, je moet sowieso ergens op klikken om die te openen.
Jammer maar helaas sta ook m’n bureaubladachtergrond op die partitie en uiteraard… die werd niet geladen tijdens het opstarten.
Werd… want ondertussen is er een werkende oplossing die ik graag met u wil delen: (en stiekem ook voor mezelf het wat gemakkelijker te maken mocht ik ooit het zelfde probleem weer tegenkomen)

Wat je moet doen is:  (waarbij sda5 de partitie is die we permanent willen mounten)

sudo vol_id -u /dev/sda5

Kopieer het resultaat van dit commando en voeg de volgende lijn toe aan /etc/fstab

#/dev/sda5
UUID=<output_of_vol_id_command> /media/sda5  ntfs defaults,nls=utf8,umask=007,gid=46 0       1

En doe dan:

sudo mount -a

Voila, bij mij werkte het alvast 😉

(via: http://ubuntuforums.org/showthread.php?t=432659 )


Een DVD afspelen in Ubuntu (9.04 – Jaunty Jackalope)

Sunday, 10 May 2009

Mijn zus had voor haar communie de dvd gekregen van hsm3 (ze is er zowat verzot op).
Uiteraard wou ik die dvd zelf ook wel eens zien en stak dus met volle moed de dvd in m’n pc, ondertussen had ik m’n stoel al achteruit gelegd en was klaar voor 112 min filmplezier.

Maar Murphy zou Murphy niet zijn moest hij ook nu weer van zich laten horen. De ene foutmelding na de andere verscheen op m’n maagdelijk zwart scherm.  Allemaal berichten met als enige boodschat: “Hey, ik kan deze DVD niet afspelen”. Zwaar vloekend en een paar verwensingen later begon ik te zoeken naar het probleem en, nu we dan toch bezig zijn, een mogelijke oplossing. Gelukkig had ik in ‘t verleden ook al zoiets voorgehad en zat Medibuntu nog in m’n lange termijn geheugen.

Na het installeren van VLC (intypen in je pakketmanager: Toepassingen > Installeren/verwijderen ) en de juiste codecs van Medibuntu (Vindt je hier) speelde de DVD probleemloos.
Akkoord, dit zijn geen actie’s die je van een gemiddelde pc-gebruiker kan en mag verwachten, maar dvd’s afspelen kan wel.
Misschien nog een puntje om in orde te brengen bij Ubuntu 😉

Ohja, en ondertussen zat ik wél achteruit in m’n zetel en heb ik uiteindelijk wel kunnen genieten van hsm3 😀


Oracle xe (her-)starten in Ubuntu

Monday, 11 May 2009

Het was spannend deze morgend. Oracle wilde maar niet starten en gaf (we zijn het al gewoon ondertussen) de ene foutmelding na de andere. 10 min voor de les begon was ik wanhopig op zoek naar wat er juist misgelopen was.
Uiteindelijk heb ik dat niet gevonden maar wat ik wél gevonden heb is hoe ik het moet oplossen.
De volgende keer als ik dit probleem heb, typ ik dus zonder twijfelen:

sudo /etc/init.d/oracle-xe restart

in de command line.


Tips voor Ubuntu 9.04

Tuesday, 9 June 2009

Belgische eID in Ubuntu gebruiken

Friday, 14 August 2009

Sinds kort heeft zowat elke Belg ze op zak zitten. Een kaartje zo groot als een bankkaart dat dienst doet als elektronische identiteitskaart. Je zou er zelfs mee kunnen inloggen op het studentenportaal van Vlaanderen om zo bijvoorbeeld je leerkrediet te kunnen raadplegen of op myMinFin.be om je belastingsaangifte digitaal door te sturen.
Het enige wat je daarvoor moet doen is een programma installeren, je browser instellen et voila, het zou moeten werken.
ZOU moeten werken, want op mijn computer deed het programma alles behalve wat het moest doen. Werken dus.

Na veel rondzoeken en nog meer uitproberen heb ik eindelijk een oplossing gevonden die voor mij (Ubuntu 9.04 / Firefox  3.5.2) werkt.
Het programma dat je terug kan vinden in de repositry’s werkte voor mij trouwens niet. Net als het programma dat je op de website van de Belgische eID zelf kan vinden.

Maar wat wel werkte is dit:

(bewerking van een mail van servicedesk@fedict.be)

De installatie van de eID software op Ubuntu 9.04 is het volgende:

(Indien je eerst de software al geinstalleerd hebt van elders: best eerst alle bestanden en dirs met *beid* en eid* en siscardplugins verwijderen in de mappen /usr/local/bin en /usr/local/lib
Anders krijg je foutmeldingen omdat er al een andere versie geïnstalleerd is.)

Open een terminal venster en voer de volgende commando’s uit:
cd /tmp
wget http://eid.belgium.be/nl/binaries/beid-middleware-3%2E5%2E2-opensuse-11%2E0-i686-5775_tcm147-59631.tgz
tar xvfz beid-middleware-3.5.2-opensuse-11.0-i686-5775_tcm147-59631.tgz
cd install
sudo ./install.sh

cd /tmp
wget http://frozenfox.freehostia.com/cappy/getlibs-all.deb
sudo dpkg -i getlibs-all.deb
sudo getlibs /usr/local/bin/beidgui

Dit loste voor mij dit probleem op:
beidgui: error while loading shared libraries: libxerces-c.so.27: cannot open shared object file: No such file or directory

Om op linux uw eID te kunnen gebruiken op Internet, wordt aangeraden om Firefox te gebruiken. Om Firefox met uw eID te kunnen gebruiken dient een PKCS#11-module te worden geïnstalleerd. Meer informatie over de installatie van deze module vindt u op http://eid.belgium.be/nl/Hoe_installeer_je_de_eID/Linux/

Aangezien de PKCS11-module voor eID enkel in een 32-bits versie beschikbaar is, dient u ook een 32-bits versie van Firefox te installeren. Hoe u dit kan doen op Ubuntu vindt u hier: https://help.ubuntu.com/community/AMD64/FirefoxAndPlugins#32-bit%20Firefox%20and%20plugins

Tip: als het niet lukt om een internetpagina te openen met de 32-bits versie van Firefox, doe dan het volgende:
1. Open Firefox
2. Typ in de adresbalk “about:config”
3. Zoek naar “network.dns.disableIPv6”
4. Zet de waarde op “true”
(Dit laatste had ik niet nodig. Het werkte zo met Firefox 3.5)

Bron: http://faunaflora.blogspot.com/2009/08/installatie-beid-kaartlezer-op-ubuntu.html


Games in Ubuntu (Linux)

Tuesday, 18 August 2009

Bestaan er dan geen spelletjes met goede graphics voor Linux?
Tuurlijk wel: http://dangerdeep.sourceforge.net/gallery.html

En ‘t is nog gratis ook! 😉